Jump to content


Photo

Pass-through variables returning null


  • This topic is locked This topic is locked
No replies to this topic

#1 DLSevertson

DLSevertson

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 06 December 2003 - 07:40 AM

Developers:

The pass-through variables in the following HTML form come back to my site with null values. Either these variables do not come back to the site at all (in which case I need to know which variables can be passed back to my site) or I am using the wrong code with which to retrieve the variables once the user returns to my site.

Here's the HTML form (specific URL references removed):

<form action="https://www.paypal.com/cgi-bin/webscr" method="post">
<input type="hidden" name="cmd" value="_xclick">
<input type="hidden" name="business" value="[my business email address]">
<input type="hidden" name="item_name" value="<%= itemName %>">
<input type="hidden" name="amount" value="<%= Basket[4] %>0">
<input type="hidden" name="invoice" value="[a random number]">
<input type="hidden" name="custom" value="[another random number]">
<input type="hidden" name="no_shipping" value="1">
<input type="hidden" name="no_note" value="1">
<input type="hidden" name="return" value="[a URL on my site]">
<input type="hidden" name="cancel_return" value="[another URL on my site]">
<input type="hidden" name="rm" value="2">
<input type="image" src="../images/bluediam.gif" class="input_image_props" name="submit" alt="Make payments with PayPal--it's fast, free, and secure!" value="I agree">
</form>

I am assuming that variables "invoice" and "custom" can come back to my site and that I retrieve them using request.getParameter(variable_name). What's wrong with this?

David




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users