Jump to content


Photo

#form.fieldnames# is undefined


  • This topic is locked This topic is locked
3 replies to this topic

#1 joe1234

joe1234

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 03 February 2004 - 04:56 PM

hey, everyone, i keep getting this error, I used the sample code, I thought maybe it's because pp is not sending me any thing, so i tried to send myself this form, someone provided this in the forum.

-------------------------------------------------------
<form method="post" action="http://www.thousandmiles.com/ipn_test.cfm">
<input type="submit" name="" value="Test IPN">
<input type="hidden" name="payment_date" value="17:53:45 Nov 5, 2002 PST">
<input type="hidden" name="txn_type" value="web_accept">
<input type="hidden" name="last_name" value="Breitenbach">
<input type="hidden" name="item_name" value="">
<input type="hidden" name="payment_gross" value="0.01">
<input type="hidden" name="mc_currency" value="USD">
<input type="hidden" name="payment_type" value="instant">
<input type="hidden" name="verify_sign" value="AlWncXKLadIepzMosHhM.VWxC0Z6AZYI0ynXRnEUma0d3RMC.TXWaJro">
<input type="hidden" name="payer_status" value="unverified">
<input type="hidden" name="payer_email" value="pb-test@paypal.com">
<input type="hidden" name="txn_id" value="01G32341KC3727119">
<input type="hidden" name="first_name" value="Patrick">
<input type="hidden" name="quantity" value="1">
<input type="hidden" name="receiver_email" value="pb-sell@paypal.com">
<input type="hidden" name="payer_id" value="QGVDAFGZ9XHLJ">
<input type="hidden" name="payment_method" value="non_cc">
<input type="hidden" name="item_number" value="">
<input type="hidden" name="payment_status" value="Completed">
<input type="hidden" name="mc_gross" value="0.01">
<input type="hidden" name="custom" value="">
<input type="hidden" name="notify_version" value="1.4">
<input type="submit" value="Test">
</form>

-------------------------------------------------------------------

but i get same error, so i guess the mistake is on my part. so what's wrong with #form.fieldnames#? I am using cf mx 6.1, there is not update for it. i am clueless, please help me.

the first few lines of the ipn_test.cfm is like everyone else's.

------------------------------------------------------------------
<CFSET str="cmd=_notify-validate">
<CFLOOP INDEX="TheField" list="#Form.FieldNames#">
<CFSET str = str & "#LCase(TheField)#=#URLEncodedFormat(Evaluate(TheField))#">
</CFLOOP>
<CFIF IsDefined("FORM.payment_date")>
<CFSET str = str & "&payment_date=#URLEncodedFormat(Form.payment_date)#">
</CFIF>
<CFIF IsDefined("FORM.subscr_date")>
<CFSET str = str & "&subscr_date=#URLEncodedFormat(Form.subscr_date)#">
</CFIF>
---------------------------------------------------------------------

#2 MultimediaGuy

MultimediaGuy

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 11 May 2004 - 07:28 AM

I have the same trouble - I wish PayPal would address this issue.

#3 simplesimon

simplesimon

    Advanced Member

  • Members
  • PipPipPip
  • 45 posts

Posted 22 May 2004 - 01:01 AM

someone posted this
<cfset x = GetHttpRequestData()>
<CFSET str="cmd=_notify-validate&" & x.content>
<CFHTTP URL="http://www.eliteweaver.co.uk/cgi-bin/webscr?#str#" METHOD="GET" RESOLVEURL="false">

i tied it and it worked 100% - haven't used it on paypal yet but i don't expect a problem

- i did notice that elite was not accissible today however.

pro.services@any-mail.co.uk

#4 Leigh

Leigh

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 26 October 2005 - 04:12 PM

Hi
This is a very ****ty CF bug (its still in CF7), but if you name a form element with some type of _'reserved word' at the end, it does not appear listed in forms.fieldnames (although the field is actually passed through the form and exists in the form structure!) The examples so far are _date and _time (eg todays_date wont work, but todaysdate or todays_dates will!)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users