Jump to content


Photo

How long should masspay API take?


  • This topic is locked This topic is locked
2 replies to this topic

#1 joshcrad

joshcrad

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 13 February 2006 - 03:34 PM

I'm setting up my masspay api which has worked a few times before. However, now, for some reason, all it's doing is taking the money out of my account and just processing. It's been three days without any activity. Is this normal? What is the average for how long it should it take.

#2 joshcrad

joshcrad

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 14 February 2006 - 10:29 AM

Thanks for the reply. I found someone else having the same problem at http://paypal.forums...1&f#1000012951. Anyone got any ideas?

#3 joshcrad

joshcrad

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 15 February 2006 - 03:06 PM

Okay, here's what's happening. I have a php script that will send money using mass payment/api and it works great when I run it manually - it subtracts the money from my account and deposits it into the receiver's account instantly.

However, I need to call it from my IPN script when I receive subscription payments. Whenever I call the sendmoney script from the IPN (or from any other test script) it subtracts the money from my account, but never adds it to the receiver's account. I've tried calling it using both:

header("Location: http://www.domain.co...name@domain.com");

and

include('http://...(same as above)...');

But neither work. And the variable seem to pass through fine. So, I don't know what the problem is. Even when I retrive the address from a database within the script, it doesn't work. I've also tried inserting the entire sendMoney script into my IPN where I need it, but that doesn't work either.

Any help would be greatly appriciated. Thanks.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users