Jump to content


Photo

#form.fieldnames#


  • This topic is locked This topic is locked
25 replies to this topic

#1 RobertD

RobertD

    Member

  • Members
  • PipPip
  • 10 posts

Posted 16 March 2003 - 11:27 AM

I have 5+ years of CF/SQL and cannot determine WHY, when PP polls my server initially, I do NOT find a #form.fieldnames#.

Has anyone else had this problem.

Did download Jason's code and he is doing the same thing.

Robert


#2 paypal_pb

paypal_pb

    Advanced Member

  • Members
  • 2,960 posts

Posted 17 March 2003 - 12:00 PM

Also have a look at: http://www.paypal.co...-pop-outside#cf

Patrick Breitenbach
PayPal, Inc.
Dev Net: https://www.paypal.com/pdn

#3 RobertD

RobertD

    Member

  • Members
  • PipPip
  • 10 posts

Posted 17 March 2003 - 08:53 PM

Thanks for the reply. It does not address the problem I am having.
The code you refer me to is SIMPLE enough.
I am NOT getting #form.fieldnames# variable. Without it, I am dead in the water. Robert


<blockquote id="quote"><font size="1" face="Verdana, Arial, Helvetica" id="quote">quote:<hr height="1" noshade id="quote">Originally posted by paypal_pb
[br]Also have a look at: http://www.paypal.co...-pop-outside#cf

Patrick Breitenbach
PayPal, Inc.
Dev Net: https://www.paypal.com/pdn
<hr height="1" noshade id="quote"></blockquote id="quote"></font id="quote">

Robert Dew
Web Agency, Inc.
Schaumburg, IL

Lead programmer
5 years plus:
- Cold Fusion
- SQL Server
- Javascript
- Windows
25 years coding non Web apps.


#4 paypal_pb

paypal_pb

    Advanced Member

  • Members
  • 2,960 posts

Posted 18 March 2003 - 01:03 AM

It's just a normal POST with FORM fields. Do you know if your script is being hit at all?

Try this: http://www.paypaldev...sp?TOPIC_ID=101

Patrick Breitenbach
PayPal, Inc.
Dev Net: https://www.paypal.com/pdn

#5 RobertD

RobertD

    Member

  • Members
  • PipPip
  • 10 posts

Posted 18 March 2003 - 07:38 AM

Absolutely - I KNOW my script is getting hit. I have an emailer in it. But I am getting NO form fields at all. Could I have something wrong in the PP end?

R

<blockquote id="quote"><font size="1" face="Verdana, Arial, Helvetica" id="quote">quote:<hr height="1" noshade id="quote">Originally posted by paypal_pb
[br]It's just a normal POST with FORM fields. Do you know if your script is being hit at all?

Try this: http://www.paypaldev...sp?TOPIC_ID=101

Patrick Breitenbach
PayPal, Inc.
Dev Net: https://www.paypal.com/pdn
<hr height="1" noshade id="quote"></blockquote id="quote"></font id="quote">

#6 paypal_pb

paypal_pb

    Advanced Member

  • Members
  • 2,960 posts

Posted 18 March 2003 - 10:20 AM

Unlikely but possible.

Did you try this: http://www.paypaldev...sp?TOPIC_ID=101

Also, it's useful to see code snippets.

Patrick Breitenbach
PayPal, Inc.
Dev Net: https://www.paypal.com/pdn

#7 RobertD

RobertD

    Member

  • Members
  • PipPip
  • 10 posts

Posted 18 March 2003 - 10:31 AM

Yes, I tried this code snippet.
But like I said PP is not sending me any form vars.
Is it something I have done wrong in the PayPal site.
I am only supposed to type in the URL for the template, right?

Robert

P.S. THis forum software VERY annoying. Have to KEEP putting my username and pwd in!!!

<blockquote id="quote"><font size="1" face="Verdana, Arial, Helvetica" id="quote">quote:<hr height="1" noshade id="quote">Originally posted by paypal_pb
[br]Unlikely but possible.

Did you try this: http://www.paypaldev...sp?TOPIC_ID=101

Also, it's useful to see code snippets.

Patrick Breitenbach
PayPal, Inc.
Dev Net: https://www.paypal.com/pdn
<hr height="1" noshade id="quote"></blockquote id="quote"></font id="quote">

#8 paypal_pb

paypal_pb

    Advanced Member

  • Members
  • 2,960 posts

Posted 18 March 2003 - 12:03 PM

Copy and paste the below into a .htm page. Modify "action" to point to your CFM script. Press "Test" button.

<form method="post" action="http://www.mysite.com/ipn.cfm">
<input type="submit" name="" value="Test IPN">
<input type="hidden" name="payment_date" value="17:53:45 Nov 5, 2002 PST">
<input type="hidden" name="txn_type" value="web_accept">
<input type="hidden" name="last_name" value="Breitenbach">
<input type="hidden" name="item_name" value="">
<input type="hidden" name="payment_gross" value="0.01">
<input type="hidden" name="mc_currency" value="USD">
<input type="hidden" name="payment_type" value="instant">
<input type="hidden" name="verify_sign" value="AlWncXKLadIepzMosHhM.VWxC0Z6AZYI0ynXRnEUma0d3RMC.TXWaJro">
<input type="hidden" name="payer_status" value="unverified">
<input type="hidden" name="payer_email" value="pb-test@paypal.com">
<input type="hidden" name="txn_id" value="01G32341KC3727119">
<input type="hidden" name="first_name" value="Patrick">
<input type="hidden" name="quantity" value="1">
<input type="hidden" name="receiver_email" value="pb-sell@paypal.com">
<input type="hidden" name="payer_id" value="QGVDAFGZ9XHLJ">
<input type="hidden" name="payment_method" value="non_cc">
<input type="hidden" name="item_number" value="">
<input type="hidden" name="payment_status" value="Completed">
<input type="hidden" name="mc_gross" value="0.01">
<input type="hidden" name="custom" value="">
<input type="hidden" name="notify_version" value="1.4">
<input type="submit" value="Test">
</form>

It's possible to save your log in to the forum so that you never have to log in again (as long as you're at the same computer).


Patrick Breitenbach
PayPal, Inc.
Dev Net: https://www.paypal.com/pdn

#9 qwert

qwert

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 19 March 2003 - 10:19 PM

robert, did you figure out the problem why PP isnt passing over the form variables needed to run your script? im also having the same problem and PP keeps telling me its a problem with my script. ive explained to them that it doesnt matter, the script doesnt run till you send me the correct variables. is it me.., or do they just not get it. is IPN even compatible with coldfusion!?

#10 RobertD

RobertD

    Member

  • Members
  • PipPip
  • 10 posts

Posted 19 March 2003 - 10:23 PM

My problem inexpicably went away. (Suggesting an error on my part?)
I am almost complete with passing control over to our bookeeping system. Sorry I cannot provide further help.

<blockquote id="quote"><font size="1" face="Verdana, Arial, Helvetica" id="quote">quote:<hr height="1" noshade id="quote">Originally posted by qwert
[br]robert, did you figure out the problem why PP isnt passing over the form variables needed to run your script? im also having the same problem and PP keeps telling me its a problem with my script. ive explained to them that it doesnt matter, the script doesnt run till you send me the correct variables. is it me.., or do they just not get it. is IPN even compatible with coldfusion!?
<hr height="1" noshade id="quote"></blockquote id="quote"></font id="quote">

Robert Dew
Web Agency, Inc.
Schaumburg, IL

Lead programmer
5 years plus:
- Cold Fusion
- SQL Server
- Javascript
- Windows
25 years coding non Web apps.


#11 MAGSGQ

MAGSGQ

    Member

  • Members
  • PipPip
  • 13 posts

Posted 07 May 2003 - 08:51 AM

Patrick

I have been trying to setup IPN with Subscription service. I notice in your IPN Test code there are variables I have not used before.
Expecially the verify_sign.

I did what you stated: http://www.coastcottages.com/test.cfm and changed to action to point to my success.cfm page.

When I run the test, I successfully view my success.cfm page, but that's it.

How the heck do I know if it were successful or not?

I suck at CFusion!

#12 MAGSGQ

MAGSGQ

    Member

  • Members
  • PipPip
  • 13 posts

Posted 07 May 2003 - 09:03 AM

Patrick,

Okay disregard my previous post. My test.cfm page works. To initially debug, I am able to output all vars and data on my success.cfm page.

However, why would it not update my dbase???

http://www.coastcottages.com/test.cfm

TIA

I suck at CFusion!

#13 RobertD

RobertD

    Member

  • Members
  • PipPip
  • 10 posts

Posted 07 May 2003 - 09:08 AM

TIA,
I take it you resolved your own problem? And you thought you sucked!? Great going. Anything I can do to help, just let me know.

Robert


Robert Dew
Web Agency, Inc.
Schaumburg, IL

Lead programmer
5 years plus:
- Cold Fusion
- SQL Server
- Javascript
- Windows
25 years coding non Web apps.


#14 MAGSGQ

MAGSGQ

    Member

  • Members
  • PipPip
  • 13 posts

Posted 07 May 2003 - 09:14 AM

Here is a dumb question. So I never got an error on my success.cfm page. How the **** do I know it passed?

It is not writing anything to my dbase. I'm not getting my emails as I should. I see the vars and data that are passed from the script, but LOL how do I know it is 100% operational?

TIA
Terry

I suck at CFusion!

#15 RobertD

RobertD

    Member

  • Members
  • PipPip
  • 10 posts

Posted 07 May 2003 - 09:16 AM

I am not even familiar with yout success.cfm page.

Something you coded? We recognize success by passing a members id to PP, then from PP response, we file the response in the member accounting data and trip an email to them to verify it posted.


[quote]Originally posted by MAGSGQ


Robert Dew
Web Agency, Inc.
Schaumburg, IL

Lead programmer
5 years plus:
- Cold Fusion
- SQL Server
- Javascript
- Windows
25 years coding non Web apps.


#16 MAGSGQ

MAGSGQ

    Member

  • Members
  • PipPip
  • 13 posts

Posted 07 May 2003 - 09:41 AM

The success.cfm code is almost identical to the easycfm.com tutorial. The only exception is I have my SQL inserts updating my datasource.

Nothing fancy about it yet. I'm still not following on how one determines if the test (test.cfm)http://www.coastcottages.com/test.cfm was successful or not?

I suck at CFusion!

#17 MAGSGQ

MAGSGQ

    Member

  • Members
  • PipPip
  • 13 posts

Posted 07 May 2003 - 10:07 AM

Here is another site I used. Here are the results, not sure what to make of it.


Thank you IPN Tester,
Your simulated IPN has been sent successfully


Your status report appears below:


IPN Creation Date: PDT
IPN Expiration Date: PDT
Send Count:
Target IPN Script: http://www.coastcott...com/success.cfm


IPN Sent: PDT
HTTP Status: HTTP/1.1 404 Object Not Found
IPN Received: Your script did not reply!
Post Back: N/A


Variables Sent:
Variables Expected: 1
Variables Received: 0


String Length Sent:
String Length Expected: 21
String Length Received: 0


Desired Response:
Actual Response: None
Intentional Response: No!


Summary: Your script is not posting back to us!


I suck at CFusion!

#18 MAGSGQ

MAGSGQ

    Member

  • Members
  • PipPip
  • 13 posts

Posted 07 May 2003 - 01:06 PM

Here is code:

<!-- read post from PayPal system and add 'cmd' -->
<CFSET str="cmd=_notify-validate">

<CFLOOP INDEX="TheField" list="#Form.FieldNames#">
<CFSET str = str & "#LCase(TheField)#=#URLEncodedFormat(Evaluate(TheField))#">
<cfif TheField IS "PAYMENT_STATUS" AND IsDefined("FORM.payment_date")>
<CFSET str = str & "&payment_date=#URLEncodedFormat(Form.payment_date)#">
</cfif>
</CFLOOP>


The transaction is successful with PayPal but this is what I get when it posts back to my success.cfm.


Error Occurred While Processing Request
Error Diagnostic Information

An error occurred while evaluating the expression:


"#Form.FieldNames#"



Error near line 4, column 33.
----------------------------------------------------------------------------
----

Error resolving parameter FORM.FIELDNAMES


The specified form field cannot be found. This problem is very likely due to the fact that you have misspelled the form field name.



The error occurred while processing an element with a general identifier of (CFLOOP), occupying document position (4:1) to (4:50).


Not sure what to do now.

I suck at CFusion!

#19 MAGSGQ

MAGSGQ

    Member

  • Members
  • PipPip
  • 13 posts

Posted 08 May 2003 - 04:51 AM

I have a really strange question, so I'll go out on a limb.
The source code Patrick provided to test with, what's the purpose of it?

I can pass any vars and data and it will always work, mind you I always get INVALID from PayPal no matter what I do.

Explain how this test code really works and proves code is setup properly, because frankly I got my hopes up thinking this code was the 'Test of all tests' seeing how Eliteweaver wasn't reliable, and to be honest I just don't see how it can verify IPN code.

Can someone elaborate?

I suck at CFusion!

#20 RobertD

RobertD

    Member

  • Members
  • PipPip
  • 10 posts

Posted 08 May 2003 - 05:05 AM

Terry. Sorry, you're being too vague. Who is Patrick? What source code? Etc. Etc.

What it is exactly that's not working? Are you getting the form variables passed yet? The first thing you're going to want to do for debugging is to dump the inbound from PP to a raw file using CFFILE. See exactly what the data stream PayPal IS SENDING you.





Robert Dew
Web Agency, Inc.
Schaumburg, IL

Lead programmer
5 years plus:
- Cold Fusion
- SQL Server
- Javascript
- Windows
25 years coding non Web apps.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users